Back to overview
Downtime

EU2 Downtime

Mar 20, 2026 at 01:04pm UTC
Affected services
pp.vnav.cloud
eu2.vnav.cloud

Resolved
Mar 20, 2026 at 02:31pm UTC

EU2 is back online

Updated
Mar 20, 2026 at 01:48pm UTC

The issue is being handled by the supplier, we are unsure how long the downtime will last.

Created
Mar 20, 2026 at 01:04pm UTC

EU2 is currently facing downtime, this is due to a disruption on supplier end. We are working on a solution.