Back to overview
Degraded
Webmail temporarily not working
Jun 10, 2026 at 7:17pm UTC
Affected services
mail.vnav.cloud
Resolved
Jun 13, 2026 at 11:17pm UTC
The issue has been found and fixed, our webmail is operable again via mail.vnav.cloud.
Affected services
Created
Jun 10, 2026 at 7:17pm UTC
Due to a technical issue, our webmail is currently unavailable. However, VNAV-hosted email addresses can still be used through an external mail client.
Connection Details
Username: your email address (e.g. example@vnav.nl)
Password: your normal webmail password
POP Service
Address: mail.vnav.cloud
Port: 110 / 995
IMAP Service
Address: mail.vnav.cloud
Port: 143 / 993
SMTP Service
Address: mail.vnav.cloud
Port: 25 / 465 / 587
We are currently working on a fix and appreciate your patience.
Affected services